Probleme mit Wiedergabe im Audioplayer

    Diese Seite verwendet Cookies. Durch die Nutzung unserer Seite erklären Sie sich damit einverstanden, dass wir Cookies setzen. Weitere Informationen

    • Probleme mit Wiedergabe im Audioplayer

      Hallo zusammen! :)

      Ich habe ein kleines Problem mit Kibo.FM in MusicBee, meinem Audioplayer, und der Fehler ist leider nicht genau zuzuordnen, ob das ein Bug der Software oder ein Problem mit dem Stream ist. Kibo ist eines von ungefähr 30 Internetradios, was ich darin integriert habe, und Kibo ist von all diesen Radios das einzige, was der Player nicht zu packen bekommt. Als Fehlermeldung wird dann eine Zeitüberschreitung beim Internetzugriff ausgegeben. Ich hab dann die Gegenprobe gemacht, aber egal ob ichs mit dem WMP, VLC oder dem normalen Webplayer probiert habe, der Stream lief einwandfrei. Endergebnis: Ich bin genauso schlau wie vorher. Das erste spricht für ein Problem mit dem Stream, das zweite für einen Bug im Player. Ich hab auch schon andere mögliche Fehlerquellen überprüft und mal die Firewall gecheckt (kein Problem dort, sonst würde er die anderen Radios ja auch nicht packen), den Codec geprüft (laut dem Seitenquelltext vom Webplayer ist das ja der normale mp3-Codec, daran wirds dann ja wohl kaum liegen) und auch den letzten Changelog von MusicBee mal durchgelesen, aber auch da gabs keine großen Änderungen, die das Problem verursacht haben könnten. Außerdem ist das Update auf die aktuelle Version 2.3 schon ein paar Wochen her und das Problem existiert erst seit ein paar Tagen.

      Frage: Hattet ihr in den letzten Tagen irgendwie am Stream gearbeitet und zum Beispiel vielleicht Wartungsarbeiten durchgeführt oder Softwareupdates eingespielt? Wäre schön, wenn ihr mir hier helfen könntet, denn dann kann ich zumindest Kibo selber als Fehlerquelle ausschließen, bevor ich dann zum Entwickler von MusicBee hinrenne und evtl. einen Bug melde, der dann vielleicht doch keiner ist. :)

      Habe die Webplayer-Adresse verwendet, hat bisher immer funktioniert, nur seit 4 oder 5 Tagen ist da der Wrum drinne.

      Liebe Grüße
      Gouryella :)
    • Dann dürfte er aber gar keine Streams kriegen und die bekommt er ja. Außerdem beobachte ich das gleiche Szenario auch in Clementine, Nightingale und aTunes, die nur zu Kibo keine Verbindung herstellen können.

      Ich tippe mittlerweile eher auf Shoutcast, weil Kibo der einzige Radiosender ist, der einen Shoutcast-Server verwendet. Nach dem Eigentümerwechsel bei Nullsoft wird da gerade kräftig umgebaut und modernisiert und da können die Services mal stark eingeschränkt sein. Von daher tippe ich mal darauf, dass ich schlichtweg einer dieser Pechvögel bin.
    • Hallo, ich habe mir das Programm grade mal auf meiner virtuellen Testmaschine installiert und konnte dort erfolgreich den Stream einbinden und auch anhören. Als Stream-URL habe ich "http://kibo.fm/kibo.pls" eingetragen. Installiert habe ich die aktuelle Version 2.3.5188. Welche Stream-URL hast du eingetragen?
      Kibo.FM - More Than Japanese Music
      Marcel - Radioleitung - Bereichsleitung Moderation, Programmierung
      Kontaktieren per: PM oder E-Mail
      Lust auf Anime und Manga?
      Jimoku
    • Bis dato die normale aus dem Webplayer (listen.kibo.fm:8000), aber letztlich kann ich auch auf den asx- und pls-Stream aufspringen, das spielt keine Rolle, er kriegt euch nicht zu packen. Die Fehlermeldung kommt trotzdem, aber eben bei keinem anderen Sender. Und ich kann mir schwer vorstellen, dass mein System gerade was genen Kibo hat ;)

      Den pls-Stream habe ich übrigens auch unter Winamp getestet, ging da auch nicht. Den asx-Stream kriegt zumindest VLC noch zu packen, ansonsten muss ich aber für Kibo auf Firefox ausweichen. Da hab ich den Webplayer in einem extra Bookmark.

      Keine Ahnung, jedenfalls ein kurioser Fehler.
      Bilder
      • Kibo Stream.png

        155,07 kB, 1.600×900, 36 mal angesehen
    • Schon seltsam, dass bei dir auch einige Verknüpfungen nicht funktionieren. Was du vielleicht ausprobieren könntest, wäre deinen DNS-Cache zu leeren (CMD->"ipconfig/flushdns"). Wenn das auch nicht funktioniert, kann ich dir leider nicht direkt sagen woran das Problem liegt, da ich den Stream über das Programm problemlos wiedergeben kann. Da müsste ich dann wirklich bitte, auf einen anderen Player zuzugreifen.

      P.S.: Gehst du über einen Proxyserver ins Internet?
      Kibo.FM - More Than Japanese Music
      Marcel - Radioleitung - Bereichsleitung Moderation, Programmierung
      Kontaktieren per: PM oder E-Mail
      Lust auf Anime und Manga?
      Jimoku
    • Ähm... über einen Proxyserver nicht, aber ganz falsch ist es nicht. Ich habe Comodo ISP als Antivirenlösung und der Internetverkehr läuft systemweit über deren DNS-Server, weil bei KDG relativ oft Störungen auftreten und weil das bei der Installation da auch ehr oder weniger automatisch passiert. Würde auch zusammenpassen, weil an dem Tag, wo ich auf euern Stream erstmals nicht mehr zugreifen konnte, CISP ein Update gefahren hat, wo neben den Malwaredefinitionen auch an der Software selber geschraubt wurde. Aber kann ein DNS-Server wirklich diese Probleme speziell bei einem einzigen Stream verursachen, wo sonst alle anderen funktionieren? Ansonsten wüsste ich nämlich nicht, wie ich auf die Schnelle einen neuen DNS-Server auftreiben sollte....

      Anderer Player bringt wie gesagt nichts und den DNS-Cache hatte ich eben geleert, Problem besteht weiterhin.

      Edit:
      Okay, ich hab jetzt wirklich nochmal alles auf links gedreht, inklusive Firewall, Tests mit Shoutcast selber, verschiedene Player, Änderung vom DNS Server, euch angepingt per Eingabeaufforderung, Router überprüft. Es kann keine Verbindung zu Kibo FM (abgesehen vom Browser, WMP und VLC, denen isses egal, ob ich den asx- oder pls-Stream nehme) hergestellt werden, selbst der Ping auf euern Streamingserver kommt wegen Zeitüberschreitung schlichtweg nicht an. Aber: Ich habs extra auch nochmal nicht nur mit normalen Webradios, sondern auch mit anderen Stationen bei Shoutcast getestet, auch da ist Kibo bei mir solo unterwegs.

      Heißt kurzum: Ich habe NUR mit Kibo ein Problem, egal wie mans dreht und wendet. Das Problem liegt also irgendwo auf dem Weg zwischen meinem Rechner und eurem Streamingserver, und da ich hier andauernd, egal ob durch die Konsole oder meine Audioplayer, ne Fehlermeldung wegen Zeitüberschreitung kriege, braucht da anscheinend irgendwas ganz schön lange, wenn euer Server auf meinen Client antworten soll. Warum, weiss der Geier... Wenn das so weitergeht, muss ich Kibo halt als einziges Webradio etwas auslagern, aber ich finds versammt ärgerlich. So einen kuriosen wie eigentlich auch saudämlichen Fehler hatte ich schon lange nicht mehr (nichts gegen euch, versteht das nicht falsch, aber für mich ist das so, als ob jemand ein Staubkorn auf ein Weizenfeld schmeisst und dann sagt "such mal").
    • So, nur zur Info, damit sich das hier (einigermaßen) auflöst:

      Nach mehrmaligen Tests weiss ich mittlerweile, dass (aus welchem Grund auch immer) der DNS-Server vom Stream nicht richtig auf mein Windows antwortet. Wenn ich die normale Domain kibo.fm anpinge, kriege ich auch eure IP-Adresse zu sehen, pinge ich direkt den Stream an, sehe ich zwar die Kennung vom DNS-Server, aber nicht die IP, und da wird dann auch wegen Zeitüberschreitung abgebrochen. Zum Vergleich habe ich mal direkt den Stream von NSW Anime angepingt, da kommt auch ganz normal die IP-Adresse. Warum gerade VLC euch aber trotzdem kriegt, weiss ich nicht so genau, kann aber daran liegen, dass der Player komplett eigene Codecs verwendet, während die anderen Player, mit denen ich es getestet habe, zumindest teilweise auf die systeminternen Codecs zurückgreifen, ist aber auch nur ne Vermutung.

      Woher das Übel tatsächlich kommt, weiss ich zwar immer noch nicht (ich würde auch nicht ausschließen, dass es am Router oder am Provider liegt, jedenfalls gabs bei Tests auch mit dem Router ab und an Probleme), andere PCs im Lan können den Stream nämlich auch nicht abspielen, aber ich hoffe mal, ich kann das irgendwann richtig fixen. Bis dahin muss halt ein Workaround her mit dem VLC.
    • Ich habe jetzt mal ein paar Schritte nachvollzogen.
      Zur Erklärung: Ich sitze hinter einer Sophos UTM9 Firewall.

      Ping auf listen.kibo.fm:

      Quellcode

      1. C:\Users\ZeroEnna>ping listen.kibo.fm
      2. Ping wird ausgeführt für listen.kibo.fm [144.76.214.91] mit 32 Bytes Daten:
      3. Antwort von 144.76.214.91: Bytes=32 Zeit=19ms TTL=50
      4. Antwort von 144.76.214.91: Bytes=32 Zeit=18ms TTL=50
      5. Antwort von 144.76.214.91: Bytes=32 Zeit=20ms TTL=50
      6. Antwort von 144.76.214.91: Bytes=32 Zeit=19ms TTL=50
      7. Ping-Statistik für 144.76.214.91:
      8. Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
      9. (0% Verlust),
      10. Ca. Zeitangaben in Millisek.:
      11. Minimum = 18ms, Maximum = 20ms, Mittelwert = 19ms
      Alles anzeigen


      ping auf Kibo.FM

      Quellcode

      1. C:\Users\ZeroEnna>ping kibo.fm
      2. Ping wird ausgeführt für kibo.fm [37.221.195.129] mit 32 Bytes Daten:
      3. Antwort von 37.221.195.129: Bytes=32 Zeit=16ms TTL=54
      4. Antwort von 37.221.195.129: Bytes=32 Zeit=18ms TTL=54
      5. Antwort von 37.221.195.129: Bytes=32 Zeit=15ms TTL=54
      6. Antwort von 37.221.195.129: Bytes=32 Zeit=17ms TTL=54
      7. Ping-Statistik für 37.221.195.129:
      8. Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
      9. (0% Verlust),
      10. Ca. Zeitangaben in Millisek.:
      11. Minimum = 15ms, Maximum = 18ms, Mittelwert = 16ms
      Alles anzeigen


      Soweit kann ich da jetzt auch erstmal nichts seltsames feststellen. Eventuell könnte Marcel auf dem Streaming-Server schauen, ob deine Pakete von der SPI gedroppt werden, aber das kann ich mir nicht vorstellen.

      Wir haben in der Vergangenheit öfter Probleme mit dem Webplayer gehabt, wobei es hier meistens an der Firefox-Config lag.
      Netzprobleme sind uns aber nicht bekannt. Wir gehen aber der Sache auf den Grund. Eventuell könntest du auch mal einen Ping auf die IP selber machen, vielleicht auch ein Trace Route. Dann können wir schauen, wo das Problem liegt.

      Grüße

      ZeroEnna
    • Besten Dank an dieser Stelle. :)

      Ich hab hier mal ne Datei angehängt. In dem Zip-Ordner sind 6 Screenshots mit 3x Ping und 3x Tracerouting auf die normale Domain, die Domain des Streamservers und auf die IP des Streamservers direkt. Der Ping und der TR direkt auf die IP ging sauber durch, bei der Domain verweigerten mir wieder die DNS-Server den Dienst.
      Dateien
    • Hi, ich hab eine kleinere Änderung vorgenommen. Dein DNS verweist die doamin listen.kibo.fm an die IPv6-Adresse. Da du den über einige Programme nicht anhören konntest, habe ich den AAAA-Record mal bearbeitet. Ich vermute einfach mal, das einige Programme mit IPv6 nicht so wirklich klakommen.
      Kibo.FM - More Than Japanese Music
      Marcel - Radioleitung - Bereichsleitung Moderation, Programmierung
      Kontaktieren per: PM oder E-Mail
      Lust auf Anime und Manga?
      Jimoku